jump to navigation

Installazione generica per i nuovi driver ATI sabato 24 novembre 2007

Posted by greenrabbit in Ati/AMD.
trackback

Per prima cosa dobbiamo disinstallare i vecchi driver precedentemente installati:

sudo dpkg -r fglrx-amdcccle
sudo dpkg -r fglrx-kernel-*
sudo dpkg -r xorg-driver-fglrx-dev
sudo dpkg -r xorg-driver-fglrx-dev
sudo rm /usr/src/fglrx-kernel*.deb

Nel caso avevate installato XGL è consigliabile rimuoverlo, perchè non serve più con i nuovi driver visto che hanno il supporto con AIGLX quindi date:

sudo apt-get remove xserver-xgl

Questi pacchetti servono per soddisfare tutte le dipendenze richieste da questi driver, se avete seguito già una volta questa guida potete anche saltare avanti altrimenti date questi comandi:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install module-assistant build-essential
sudo apt-get install fakeroot dh-make \
debconf libstdc++5 gcc-3.3-base \
linux-headers-generic

Esistono due tipi di driver quelli per i sistemi a 32 bit, li potete scaricare da questo link, oppure per i sistemi a 64 bit, li troverete su questo link una volta terminato il download date i seguenti comandi da terminale:

chmod +x ati-driver-installer-*.run

./ati-driver-installer-*.run --buildpkg Ubuntu/gutsy

Installate i pacchetti appena creati:

sudo dpkg -i xorg-driver-fglrx_*.deb
sudo dpkg -i fglrx-kernel-source_*.deb
sudo dpkg -i fglrx-amdcccle_*.deb
sudo dpkg -i xorg-driver-fglrx-dev_*.deb

Compilate, pacchettizzate e installate il modulo:

sudo m-a update
sudo m-a prepare
sudo m-a build fglrx
sudo m-a install fglrx

Prima di riavviare una piccolo accorgimento che dovrebbe essere valido solo per una prima installazione, se prima di questi driver utilizzavate quelli presenti nei repository ufficiali è necessario disabilitare i vecchi sostituendo all’interno del file:

sudo nano /etc/default/linux-restricted-modules-common

la riga:

DISABLED_MODULES=""

con la riga

DISABLED_MODULES="fglrx"

Abilitare i driver proprietari da “restricted manager”, questo passo è FONDAMENTALE per la buona riuscita dell’installazione.

Fatto questo riavviate il sistema e date il comando:

fglrxinfo

Dovreste ottenere come risultato:

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 2400 PRO
OpenGL version string: 2.0.6958 Release

Se al posto di ATI vi esce Mesa il sistema non carica ancora il modulo per l’accelerazione 3D, significa che precedentemente non avete installato il pacchetto:

linux-restricted-modules-$(uname -r)

per farlo caricare correttamente date questi comandi:

sudo mkdir /lib/modules/$(uname -r)/misc/
sudo mkdir /lib/modules/$(uname -r)/volatile/

controllate che all’interno della cartella:

/lib/modules/$(uname -r)/misc/

sia presente il driver fglrx.ko, e create il link simbolico:

sudo ln -s /lib/modules/$(uname -r)/misc/fglrx.ko /lib/modules/$(uname -r)/volatile/fglrx.ko

fatto questo riavviate il server X.

C’è anche un modo più veloce per installare i driver e cioè utilizzare lo script aggiornato che troverete nel sito di Alberto Milone .

Per abilitare compiz bisogna editare il file:

sudo nano /usr/bin/compiz

e aggiungere in white list il driver fglrx:

# Driver whitelist
WHITELIST=”nvidia intel ati fglrx radeon i810″

Controllate anche la black list per vedere se la vostra scheda è tra quelle, in tal caso toglietela commentando la voce.

Un ultimo sguardo al file Xorg per cancellare le voci relative a Aiglx e Composite, che oramai sono diventate obsolete con l’arrivo di Gutsy perchè le carica di default con il sistema.

Commenti»

1. Freedreamer - sabato 24 novembre 2007

novità nelle prestazioni?

2. Luca - domenica 25 novembre 2007

ehm piccolo problemino: durante la riproduzione di filmati (sia Totem, che VLC, che Mplayer) non si vede assolutamente niente. Se riavvio il pc si vede solo mettendolo a tutto schermo. Capita anche a voi? Ho utilizzato Envy per installare.

3. greenrabbit - lunedì 26 novembre 2007

@Freedreamer non saprei dirti🙂
@Luca questo problema c’era anche con la vecchia versione di driver, ma capita solo con compiz attivato🙂


Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: